import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+)-(0[1-9]|1[012])-(0[1-9]|[12]\\d|3[01])_([01]\\d|2[0-3]):([0-5]\\d):([0-5]\\d|60)(\\.\\d+)?(([Zz])|([\\+|\\-]([01]\\d+|2[0-3])))";
final String string = "2018-05-12_04:26:57.525+0000: [I] Accepted and connected to 9.4.127.199 ng.zc2.zurich <c0n9>\n"
+ "2018-05-28_09:01:01.825813-04:00 elastic-nfs-test systemd: Created slice User Slice of root.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}