$re = '/\S*rgo1\S*\.html/m';
$str = 'file.html test string something filergo1something.html
ergo1.html some more text
rgo1.html
fileergo1.html
file.html
test text f_ergo1-ss.html test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);