const regex = /\S*rgo1\S*\.html/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\S*rgo1\\S*\\.html', 'gm')
const str = `file.html test string something filergo1something.html
ergo1.html some more text
rgo1.html
fileergo1.html
file.html
test text f_ergo1-ss.html test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}