package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\S*rgo1\S*\.html`)
var str = `file.html test string something filergo1something.html
ergo1.html some more text
rgo1.html
fileergo1.html
file.html
test text f_ergo1-ss.html test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}