import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\S*rgo1\\S*\\.html";
final String string = "file.html test string something filergo1something.html\n\n"
+ "ergo1.html some more text\n"
+ "rgo1.html\n"
+ "fileergo1.html\n"
+ "file.html\n"
+ "test text f_ergo1-ss.html test";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}