// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m) #(([0-9A-F]{6})|([0-9a-f]{6}))").unwrap();
let string = "Hexadecimal color values are supported in all browsers.
A hexadecimal color is specified with: #RRGGBB. RR (red), GG (green) and BB (blue) are
hexadecimal integers between 00 and FF specifying the intensity of the color.
For example, #0000FF is displayed as blue, because the blue component is set to its
highest value (FF) and the others are set to 00.
You can use upper case or lower case letters to specify hexadecimal values : #6A95ED
or #6a95ed.
12
12
123
123
23
2
+12
12
-1
1
-2
00 00
+2
+9
-7
+3445";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}