const regex = / #(([0-9A-F]{6})|([0-9a-f]{6}))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' #(([0-9A-F]{6})|([0-9a-f]{6}))', 'gm')
const str = `Hexadecimal color values are supported in all browsers.
A hexadecimal color is specified with: #RRGGBB. RR (red), GG (green) and BB (blue) are
hexadecimal integers between 00 and FF specifying the intensity of the color.
For example, #0000FF is displayed as blue, because the blue component is set to its
highest value (FF) and the others are set to 00.
You can use upper case or lower case letters to specify hexadecimal values : #6A95ED
or #6a95ed.
12
12
123
123
23
2
+12
12
-1
1
-2
00 00
+2
+9
-7
+3445`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}