use strict;
my $str = 'Hexadecimal color values are supported in all browsers.
A hexadecimal color is specified with: #RRGGBB. RR (red), GG (green) and BB (blue) are
hexadecimal integers between 00 and FF specifying the intensity of the color.
For example, #0000FF is displayed as blue, because the blue component is set to its
highest value (FF) and the others are set to 00.
You can use upper case or lower case letters to specify hexadecimal values : #6A95ED
or #6a95ed.
12
12
123
123
23
2
+12
12
-1
1
-2
00 00
+2
+9
-7
+3445';
my $regex = qr/ #(([0-9A-F]{6})|([0-9a-f]{6}))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}