import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " #(([0-9A-F]{6})|([0-9a-f]{6}))";
final String string = "Hexadecimal color values are supported in all browsers.\n"
+ "A hexadecimal color is specified with: #RRGGBB. RR (red), GG (green) and BB (blue) are\n"
+ "hexadecimal integers between 00 and FF specifying the intensity of the color.\n"
+ "For example, #0000FF is displayed as blue, because the blue component is set to its\n"
+ "highest value (FF) and the others are set to 00.\n"
+ "You can use upper case or lower case letters to specify hexadecimal values : #6A95ED\n"
+ "or #6a95ed.\n\n\n"
+ "12\n"
+ "12 \n"
+ "123\n"
+ "123\n"
+ "23\n"
+ "2\n"
+ "+12\n"
+ "12\n"
+ "-1\n"
+ "1\n"
+ "-2\n"
+ "00 00\n"
+ "+2\n"
+ "+9\n"
+ "-7\n"
+ "+3445";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}