import Foundation
let pattern = #"^X-Mimecast-Spam-Score\: \b([7-9]|[12][0-9])\b\nX\-Mimecast\-Spam\-Signature\: yes$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
MIME-Version: 1.0
X-Mailer: WebService/1.1.19306 YMailNorrin
Authentication-Results: relay.mimecast.com;
dkim=pass header.d=yahoo.com header.s=s2048 header.b=XXXXXX;
dmarc=pass (policy=reject) header.from=yahoo.com;
spf=pass (relay.mimecast.com: domain of XXXXXX@yahoo.com designates 106.10.241.82 as permitted sender) smtp.mailfrom=XXXXXXXXXX@yahoo.com
X-Mimecast-Spam-Score: 15
X-Mimecast-Spam-Signature: yes
Content-Type: multipart/alternative;
boundary="----=_Part_966462_2108451314.1637042911940"
Content-Length: 55093
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)