# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^X-Mimecast-Spam-Score\: \b([7-9]|[12][0-9])\b\nX\-Mimecast\-Spam\-Signature\: yes$"
test_str = ("MIME-Version: 1.0\n"
"X-Mailer: WebService/1.1.19306 YMailNorrin\n"
"Authentication-Results: relay.mimecast.com;\n"
"dkim=pass header.d=yahoo.com header.s=s2048 header.b=XXXXXX;\n"
"dmarc=pass (policy=reject) header.from=yahoo.com;\n"
"spf=pass (relay.mimecast.com: domain of XXXXXX@yahoo.com designates 106.10.241.82 as permitted sender) smtp.mailfrom=XXXXXXXXXX@yahoo.com\n"
"X-Mimecast-Spam-Score: 15\n"
"X-Mimecast-Spam-Signature: yes\n"
"Content-Type: multipart/alternative;\n"
"boundary=\"----=_Part_966462_2108451314.1637042911940\"\n"
"Content-Length: 55093")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.