using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^X-Mimecast-Spam-Score\: \b([7-9]|[12][0-9])\b\nX\-Mimecast\-Spam\-Signature\: yes$";
string input = @"MIME-Version: 1.0
X-Mailer: WebService/1.1.19306 YMailNorrin
Authentication-Results: relay.mimecast.com;
dkim=pass header.d=yahoo.com header.s=s2048 header.b=XXXXXX;
dmarc=pass (policy=reject) header.from=yahoo.com;
spf=pass (relay.mimecast.com: domain of XXXXXX@yahoo.com designates 106.10.241.82 as permitted sender) smtp.mailfrom=XXXXXXXXXX@yahoo.com
X-Mimecast-Spam-Score: 15
X-Mimecast-Spam-Signature: yes
Content-Type: multipart/alternative;
boundary=""----=_Part_966462_2108451314.1637042911940""
Content-Length: 55093";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}