import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^X-Mimecast-Spam-Score\\: \\b([7-9]|[12][0-9])\\b\\nX\\-Mimecast\\-Spam\\-Signature\\: yes$";
final String string = "MIME-Version: 1.0\n"
+ "X-Mailer: WebService/1.1.19306 YMailNorrin\n"
+ "Authentication-Results: relay.mimecast.com;\n"
+ "dkim=pass header.d=yahoo.com header.s=s2048 header.b=XXXXXX;\n"
+ "dmarc=pass (policy=reject) header.from=yahoo.com;\n"
+ "spf=pass (relay.mimecast.com: domain of XXXXXX@yahoo.com designates 106.10.241.82 as permitted sender) smtp.mailfrom=XXXXXXXXXX@yahoo.com\n"
+ "X-Mimecast-Spam-Score: 15\n"
+ "X-Mimecast-Spam-Signature: yes\n"
+ "Content-Type: multipart/alternative;\n"
+ "boundary=\"----=_Part_966462_2108451314.1637042911940\"\n"
+ "Content-Length: 55093";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}