re = /[^ ]+\b/
str = 'I don\'t want any toast, and he doesn\'t want any toast. In fact, no-one around here wants any toast. Not now, not ever. No toast.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end