using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^ ]+\b";
string input = @"I don't want any toast, and he doesn't want any toast. In fact, no-one around here wants any toast. Not now, not ever. No toast.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}