$re = '/[^ ]+\b/';
$str = 'I don\'t want any toast, and he doesn\'t want any toast. In fact, no-one around here wants any toast. Not now, not ever. No toast.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);