package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^ ]+\b`)
var str = `I don't want any toast, and he doesn't want any toast. In fact, no-one around here wants any toast. Not now, not ever. No toast.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}