import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[\\(])*([\\d]{3,3})(?:[\\)\\.\\ ])*([\\d]{3,3})(?:[\\-\\.])*([\\d]{4,4})";
final String string = "586.943.9341\n"
+ "5869439241\n"
+ "(586)123-4567\n"
+ "(586) 943-9341";
final String subst = "$1-$2-$3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}