# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:[\(])*([\d]{3,3})(?:[\)\.\ ])*([\d]{3,3})(?:[\-\.])*([\d]{4,4})/$1-$2-$3/g;t' <<< "586.943.9341
5869439241
(586)123-4567
(586) 943-9341"