using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[\(])*([\d]{3,3})(?:[\)\.\ ])*([\d]{3,3})(?:[\-\.])*([\d]{4,4})";
string substitution = @"$1-$2-$3";
string input = @"586.943.9341
5869439241
(586)123-4567
(586) 943-9341";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}