package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:[\(])*([\d]{3,3})(?:[\)\.\ ])*([\d]{3,3})(?:[\-\.])*([\d]{4,4})`)
var str = `586.943.9341
5869439241
(586)123-4567
(586) 943-9341`
var substitution = "$1-$2-$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}