$re = '/;(?=$|\s*})/m';
$str = 'let a; let b
let c;
let d
while (!0) { break; }';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;