use strict;
my $str = 'let a; let b
let c;
let d
while (!0) { break; }';
my $regex = qr/;(?=$|\s*})/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";