# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/;(?=$|\s*})//gm;t' <<< "let a; let b
let c;
let d
while (!0) { break; }"