#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m);(?=$|\s*})"
Local $sString = "let a; let b" & @CRLF & _
"let c;" & @CRLF & _
"let d" & @CRLF & _
"" & @CRLF & _
"while (!0) { break; }"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)