import Foundation
let pattern = #"^\|\s(.[^|]+)\s\|"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
| | |
|---|---|
| Answering Machine Messages | When the system is set up to detect answering machines on outbound calls, and it detects one, then it plays this message for the customer to listen later on. |
| Connect Messages | Message played/sent to the caller immediately before delivering call to the selected operator. |
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)