$re = '/^\|\s(.[^|]+)\s\|/m';
$str = '| | |
|---|---|
| Answering Machine Messages | When the system is set up to detect answering machines on outbound calls, and it detects one, then it plays this message for the customer to listen later on. |
| Connect Messages | Message played/sent to the caller immediately before delivering call to the selected operator. |';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);