#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\|\s(.[^|]+)\s\|"
Local $sString = "| | |" & @CRLF & _
"|---|---|" & @CRLF & _
"| Answering Machine Messages | When the system is set up to detect answering machines on outbound calls, and it detects one, then it plays this message for the customer to listen later on. |" & @CRLF & _
"| Connect Messages | Message played/sent to the caller immediately before delivering call to the selected operator. |"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")