re = /^\|\s(.[^|]+)\s\|/m
str = '| | |
|---|---|
| Answering Machine Messages | When the system is set up to detect answering machines on outbound calls, and it detects one, then it plays this message for the customer to listen later on. |
| Connect Messages | Message played/sent to the caller immediately before delivering call to the selected operator. |'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end