# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"(?xsm)\n"
r"(.+) # copy-past replacement to ")
test_str = ("=IFERROR(\n"
" MAX(\n"
" INDEX(\n"
" raw_wells_prod!R1,\n"
" MATCH(\n"
" 1,\n"
" raw_wells_prod!R,\n"
" 0\n"
" )\n"
" ),\n"
" INDEX(\n"
" raw_wells_inj!R1,\n"
" MATCH(\n"
" 1,\n"
" raw_wells_prod!R,\n"
" 0\n"
" )\n"
" )\n"
" ),\n"
" 0\n"
") ")
subst = "$1 "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.