use strict;
my $str = '=IFERROR(
MAX(
INDEX(
raw_wells_prod!R1,
MATCH(
1,
raw_wells_prod!R,
0
)
),
INDEX(
raw_wells_inj!R1,
MATCH(
1,
raw_wells_prod!R,
0
)
)
),
0
) ';
my $regex = qr/(?xsm)
(.+) # copy-past replacement to /mp;
my $subst = '$1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";