# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?xsm)
(.+) # copy-past replacement to /$1 /gm;t' <<< "=IFERROR(
MAX(
INDEX(
raw_wells_prod!R1,
MATCH(
1,
raw_wells_prod!R,
0
)
),
INDEX(
raw_wells_inj!R1,
MATCH(
1,
raw_wells_prod!R,
0
)
)
),
0
) "