const regex = /(?xsm)
(.+) # copy-past replacement to /gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?xsm)
(.+) # copy-past replacement to ', 'gm')
const str = `=IFERROR(
MAX(
INDEX(
raw_wells_prod!R1,
MATCH(
1,
raw_wells_prod!R,
0
)
),
INDEX(
raw_wells_inj!R1,
MATCH(
1,
raw_wells_prod!R,
0
)
)
),
0
) `;
const subst = `$1 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);