re = /(?<=\/\/\s*COLORS)[\r\n]+(.*)(?=\/\/\s*END\s*COLORS)/m
str = '// COLORS
$nipiter-green : #158C3F;
$green : #048e3c;
$light-green : #C4E2CF;
$nipiter-red : #e11b1c;
$dark-red : #a11b1b;
$black : #000000;
$dark-gray : #4c4c4c;
$gray : #e4e4e4;
$white : #ffffff;
$transparent-white : rgba(255, 255, 255, 0.59);
$feminist-purple : #2a1736;
$yellow : #ffff73;
$twitter-blue : #5a8dbd;
$facebook-blue : #184f83;
// END COLORS'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end