import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\/\\/\\s*COLORS)[\\r\\n]+(.*)(?=\\/\\/\\s*END\\s*COLORS)";
final String string = "// COLORS\n"
+ "$nipiter-green : #158C3F;\n"
+ "$green : #048e3c;\n"
+ "$light-green : #C4E2CF;\n"
+ "$nipiter-red : #e11b1c;\n"
+ "$dark-red : #a11b1b;\n"
+ "$black : #000000;\n"
+ "$dark-gray : #4c4c4c;\n"
+ "$gray : #e4e4e4;\n"
+ "$white : #ffffff;\n"
+ "$transparent-white : rgba(255, 255, 255, 0.59);\n"
+ "$feminist-purple : #2a1736;\n\n"
+ "$yellow : #ffff73;\n"
+ "$twitter-blue : #5a8dbd;\n"
+ "$facebook-blue : #184f83;\n"
+ "// END COLORS";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}