const regex = /(?<=\/\/\s*COLORS)[\r\n]+(.*)(?=\/\/\s*END\s*COLORS)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\\/\\\/\\s*COLORS)[\\r\\n]+(.*)(?=\\\/\\\/\\s*END\\s*COLORS)', 'gms')
const str = `// COLORS
\$nipiter-green : #158C3F;
\$green : #048e3c;
\$light-green : #C4E2CF;
\$nipiter-red : #e11b1c;
\$dark-red : #a11b1b;
\$black : #000000;
\$dark-gray : #4c4c4c;
\$gray : #e4e4e4;
\$white : #ffffff;
\$transparent-white : rgba(255, 255, 255, 0.59);
\$feminist-purple : #2a1736;
\$yellow : #ffff73;
\$twitter-blue : #5a8dbd;
\$facebook-blue : #184f83;
// END COLORS`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}