use strict;
my $str = '// COLORS
$nipiter-green : #158C3F;
$green : #048e3c;
$light-green : #C4E2CF;
$nipiter-red : #e11b1c;
$dark-red : #a11b1b;
$black : #000000;
$dark-gray : #4c4c4c;
$gray : #e4e4e4;
$white : #ffffff;
$transparent-white : rgba(255, 255, 255, 0.59);
$feminist-purple : #2a1736;
$yellow : #ffff73;
$twitter-blue : #5a8dbd;
$facebook-blue : #184f83;
// END COLORS';
my $regex = qr/(?<=\/\/\s*COLORS)[\r\n]+(.*)(?=\/\/\s*END\s*COLORS)/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}