// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"Password\s*(.*)\s*Website\s(.*)").unwrap();
let string = "Sample 6
GeraldRGerrard@dayrep.com
This is a real email address. Click here to activate it!
Username Vier1988
Password uach3eiSohp
Website
thefamilytrust.com
Browser user agent
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.103 Safari/537.36 OPR/60.0.3255.95";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}