import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Password\\s*(.*)\\s*Website\\s(.*)";
final String string = "Sample 6\n"
+ "GeraldRGerrard@dayrep.com\n"
+ "This is a real email address. Click here to activate it!\n"
+ "Username Vier1988\n"
+ "Password uach3eiSohp\n"
+ "Website\n"
+ "thefamilytrust.com\n"
+ "Browser user agent\n"
+ "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.103 Safari/537.36 OPR/60.0.3255.95";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}