const regex = /Password\s*(.*)\s*Website\s(.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Password\\s*(.*)\\s*Website\\s(.*)', 'g')
const str = `Sample 6
GeraldRGerrard@dayrep.com
This is a real email address. Click here to activate it!
Username Vier1988
Password uach3eiSohp
Website
thefamilytrust.com
Browser user agent
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.103 Safari/537.36 OPR/60.0.3255.95`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}