import Foundation
let pattern = #"(?:.*\(.*)(\+|-{1})(?: )(\d+\.*?\d+)(?:.*\))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
option 1 ( + 10.2$ )
option 2 ( - 110.00$ )
option 2 ( - 110$ )
option 2 ( + 0.1$ )
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)