use strict;
my $str = 'option 1 ( + 10.2$ )
option 2 ( - 110.00$ )
option 2 ( - 110$ )
option 2 ( + 0.1$ )
';
my $regex = qr/(?:.*\(.*)(\+|-{1})(?: )(\d+\.*?\d+)(?:.*\))/ip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";