using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:.*\(.*)(\+|-{1})(?: )(\d+\.*?\d+)(?:.*\))";
string substitution = @"";
string input = @"option 1 ( + 10.2$ )
option 2 ( - 110.00$ )
option 2 ( - 110$ )
option 2 ( + 0.1$ )
";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}