#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(?:.*\(.*)(\+|-{1})(?: )(\d+\.*?\d+)(?:.*\))"
Local $sString = "option 1 ( + 10.2$ )" & @CRLF & _
"option 2 ( - 110.00$ )" & @CRLF & _
"option 2 ( - 110$ )" & @CRLF & _
"option 2 ( + 0.1$ )" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)