import Foundation
let pattern = #"^(?<x_forwarded_for>(?:[0-9:.-]*, )?(?<clientip>[0-9:.-]*)) (?<ident>[^ ]*) (?<auth>[^ ]*) \[(?<time>[^\]]*)\] "(?<verb>\S+)(?: +(?<request>[^\"]*?)(?: +(?<httpversion>\S*))?)?" (?<response>[^ ]*) (?<bytes>[^ ]*) "(?<referer>[^\"]*)" "(?<agent>[^\"]*)" "(?<request_time>[^\"]*)" "(?<host>[^\"]*)(?::(?<host_port>\S+))?"(?: ATI:"(?<amazn_trace_id>[^\"]*)")?(?: "(?<hdr_location>[^\"]*)" "(?<request_length>[^\"]*)")?(?: "(?<tls_version>[^\/]*)\/(?<tls_cipher>[^\"]*)")?(?: trace_id:"(?<a0_request_id>[^\"]*)")?$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"- - - [15/Jan/2020:15:05:36 +0000] "GET / HTTP/1.1" 200 14 "-" "curl/7.54.0" "0.000" "localhost:8888" ATI:"-" "-" "78" "-/-" trace_id:"6-1579100736.791-172.17.0.1-78""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}