package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?<x_forwarded_for>(?:[0-9:.-]*, )?(?<clientip>[0-9:.-]*)) (?<ident>[^ ]*) (?<auth>[^ ]*) \[(?<time>[^\]]*)\] "(?<verb>\S+)(?: +(?<request>[^\"]*?)(?: +(?<httpversion>\S*))?)?" (?<response>[^ ]*) (?<bytes>[^ ]*) "(?<referer>[^\"]*)" "(?<agent>[^\"]*)" "(?<request_time>[^\"]*)" "(?<host>[^\"]*)(?::(?<host_port>\S+))?"(?: ATI:"(?<amazn_trace_id>[^\"]*)")?(?: "(?<hdr_location>[^\"]*)" "(?<request_length>[^\"]*)")?(?: "(?<tls_version>[^\/]*)\/(?<tls_cipher>[^\"]*)")?(?: trace_id:"(?<a0_request_id>[^\"]*)")?$`)
var str = `- - - [15/Jan/2020:15:05:36 +0000] "GET / HTTP/1.1" 200 14 "-" "curl/7.54.0" "0.000" "localhost:8888" ATI:"-" "-" "78" "-/-" trace_id:"6-1579100736.791-172.17.0.1-78"`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}