import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<x_forwarded_for>(?:[0-9:.-]*, )?(?<clientip>[0-9:.-]*)) (?<ident>[^ ]*) (?<auth>[^ ]*) \\[(?<time>[^\\]]*)\\] \"(?<verb>\\S+)(?: +(?<request>[^\\\"]*?)(?: +(?<httpversion>\\S*))?)?\" (?<response>[^ ]*) (?<bytes>[^ ]*) \"(?<referer>[^\\\"]*)\" \"(?<agent>[^\\\"]*)\" \"(?<request_time>[^\\\"]*)\" \"(?<host>[^\\\"]*)(?::(?<host_port>\\S+))?\"(?: ATI:\"(?<amazn_trace_id>[^\\\"]*)\")?(?: \"(?<hdr_location>[^\\\"]*)\" \"(?<request_length>[^\\\"]*)\")?(?: \"(?<tls_version>[^\\/]*)\\/(?<tls_cipher>[^\\\"]*)\")?(?: trace_id:\"(?<a0_request_id>[^\\\"]*)\")?$";
final String string = "- - - [15/Jan/2020:15:05:36 +0000] \"GET / HTTP/1.1\" 200 14 \"-\" \"curl/7.54.0\" \"0.000\" \"localhost:8888\" ATI:\"-\" \"-\" \"78\" \"-/-\" trace_id:\"6-1579100736.791-172.17.0.1-78\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}