$re = '/(?<=groups\/)(?<id>[0-9]+)|(?<=groups\/)(?<username>[a-zA-Z\.\_0-9]+)/m';
$str = 'https://www.facebook.com/groups/164062097331207/?ref=group_browse_new
https://www.facebook.com/groups/j2team.community/?ref=group_browse_new
https://www.facebook.com/groups/j2team.community.banned/?ref=group_browse_new';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);