import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=groups\\/)(?<id>[0-9]+)|(?<=groups\\/)(?<username>[a-zA-Z\\.\\_0-9]+)";
final String string = "https://www.facebook.com/groups/164062097331207/?ref=group_browse_new\n"
+ "https://www.facebook.com/groups/j2team.community/?ref=group_browse_new\n"
+ "https://www.facebook.com/groups/j2team.community.banned/?ref=group_browse_new";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}