use strict;
my $str = 'https://www.facebook.com/groups/164062097331207/?ref=group_browse_new
https://www.facebook.com/groups/j2team.community/?ref=group_browse_new
https://www.facebook.com/groups/j2team.community.banned/?ref=group_browse_new';
my $regex = qr/(?<=groups\/)(?<id>[0-9]+)|(?<=groups\/)(?<username>[a-zA-Z\.\_0-9]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}